Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

XP Save Setup

xp save

  • Please log in to reply
4 replies to this topic

#1
OFFLINE   JvIasterMind

JvIasterMind

    Regular Member

  • Members
  • PipPipPip
  • 116 posts
8
A step in the right direction
I am having a slight problem getting xpsave to work how I want it. I am trying to make it reset after 60 hours, but currently the xp seems to be ignoring the XPSaveMaxAge variables.

Here are the settings that I am using...
set g_dbUserMaxAge "12o"
set g_XPSave "27"
set g_XPSaveMaxAge_xp "60h"
set g_XPSaveMaxAge "60h"
set g_XPSaveMinXP "0"
set g_maxXP "-1"
set g_maxXPResetWarn "0"
set g_XPDecay "0"

I also tried setting both g_XPSaveMaxAge_xp and g_XPSaveMaxAge to 2m, with the same result. Note: I had the same problem in all of the versions of silEnT that I tested (0.3.3, 0.4.0, and 0.5.0). I have tried a bunch of different setting combinations without luck.

Edited by JvIasterMind, 09 December 2011 - 07:57 AM.


#2
OFFLINE   JvIasterMind

JvIasterMind

    Regular Member

  • Members
  • PipPipPip
  • 116 posts
8
A step in the right direction
Anybody here have a working timelimit on XPSave?

My clan is switching over to silEnT tonight and we really need to get this sorted out.

#3
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
I tested locally both of the values: g_XPSaveMaxAge_xp and g_XPSaveMaxAge. They worked.

This is what I had in g_XPSave.
g_XPSave 27
I tested g_XPSaveMaxAge_XP "2m"
and
g_XPSaveMaxAge "1m"
separately.

If you test short times, please note that if you reconnect during the samemap, the gained XP is still in the buffers and not resetted. So use !nextmap in between.

Could you check the actual used values using rcon commands while the server is online to see if they are in effect?

#4
OFFLINE   JvIasterMind

JvIasterMind

    Regular Member

  • Members
  • PipPipPip
  • 116 posts
8
A step in the right direction
Did a little bit of testing and it seems to be working for 2 minutes. When I tested it before, I didn't do the !nextmap command.

I'll let you know if it is working at 60 hours.

#5
OFFLINE   JvIasterMind

JvIasterMind

    Regular Member

  • Members
  • PipPipPip
  • 116 posts
8
A step in the right direction
It is working fine on our main server. No clue why it wasn't working on my testing server. I'll see if I can look into it and do some more testing at some point.





Also tagged with one or more of these keywords: xp save

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users