Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Punkbuster kicks


  • Please log in to reply
25 replies to this topic

#1
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
Hi,

Thanks to Hellreturn our test server is up and running hte SilentMod.

But, when we played there this afternoon with 3 clanmembers we all got a Punkbuster kick.

Disallowed prgram driver (120152)

We only have this kick on the SilentMod server.

When we play on our Jaymod or Nq server we don't have this kick.

First i wanted it to report it in the PBbans forum, but we think its related to this mod.

Anny ideas?

#2
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
The kick happens also with many other games then just ET. I will connect to your server and play there a while to see do I get kicked. I usually get no kicks at all on PB servers.

Indeed, the mod hasn't been tested yet with punkbuster on.

#3
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
The server is password protected. Would it be possible if i could get the password for visiting there?

#4
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
Yes please try.

But i can ensure you all 4 servers i run have the same pb version on it.
Only the Silent server kicks for this.

#5
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
I send you the password by Pm.

#6
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
I got kicked too for that.

I did some searching for the net about it and it seems it does happen with other mods too, but I didn't find clear reasons why.
I also found this from pbbans, http://www.pbbans.co...ns-t103570.html , your using 1 or 2 as the setting value?

#7
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
Nice you got kicked too :P

I have no idea what sort of setting they mean.
But, i also read its a Pup kick, and about the macro's.
When it is a macro kick i have big troubles with it, i have 5 keybords and mouses, they all support macros..
I don't have a non macro key or mouse, to test it.

And i can ensure you al my pb files are the same on the 4 servers i run, stock settings files from PBbans MCi.
And in my 2 Jaymod and 1 NQ servers we don't get these kicks.

Edit, not all is stock, but on the silent server they are.
In jaymod i restricked some bob settings. But that has nothing to do with it.

#8
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
http://www.pbbans.co...581#entry338581

#9
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
Ok for now i have a solution. I disaible Pb on that server.
Pbbans advice you to make a trouble ticket at evenbalance.

#10
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
My mouse supports MACROS too. I don't have normal mouse here with me to test it either.

I will start a punkbuster server with silEnT later today to see if it is something that generally happens with silent mod. I can also ensure that we haven't touched punkbuster code while making the mod :P.

#11
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
I have now tested versions latest 0.1.8 and the downlaodable version from this forum 0.1.4 with punkbuster enabled. For a longer while without getting kicked. The punkbuster settings are stock settings.

The issue is with the pb settings.

About making a trouble ticket to evenbalance.

First of all, that response in the pbbans thread was given with very little understanding of punkbuster. We have indeed not written any program drivers into the mod. Also, I don't think this is a punkbuster bug either, as I have been unable to get kicked with stock punkbuster settings.

#12
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
You said you have the exact same settings then with your other server. This sounds like you have copy pasted the pb files from other installations. Like I said, I haven't had any problems. I even enabled the punkbuster on my public server today. It is now waiting to start streaming to the pbbans. For proper installing of punkbuster I recommend you to delete the pb folder, start your server pb enabled and wait some 30 minutes for the punkbuster to autopupdate on the server. Then to get good configurations, use the hub tool from pbbans that will write the pbsv.cfg for your server. After that, it is up to you will you put the cvar/MD5 scans active to your server.

#13
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame
Hi Tosa_Inu,

I notice, you have HD ET on your server. Can you please replace it with regular packs and see if issue exists?

To test, please change your modified etmain packs to default one, i.e. pak0.pk3, pak1.pk3 and pak2.pk3.

I am assuming, that will fix your issue and if it doesn't we can look more into it.

Thanks!

#14
OFFLINE   Tosa_Inu

Tosa_Inu

    Regular Member

  • Members
  • PipPipPip
  • 120 posts
13
A step in the right direction
I removed the ethd file.
I enabled pb, and the streaming.
First it looked like it was without a pb kick.
I left after 10 min
A clanmember of mine played on and he got kicked after 5 min.
So i reconnect and got a kick to.
Afterwards we get kicked after 2-3 min.

All files are standard in etmain.

There are some modified clan files in the server.cfg map, but those also run on my other 3 servers without pb problems.

Maybe it has someting to do with the streaming settings or the md5tool?

#15
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame
md5tool and any PB configs as nothing to do with it. I will set up testing server tonight on my machine and then I will PM you IP and such.

Please, test it on our server and see if you are still getting kicked.

#16
OFFLINE   foxdie

foxdie

    Newbie

  • Members
  • Pip
  • 2 posts
0
Unknown
This violation is caused by unknown vmMain pattern or vmMain pointer hook. You need to contact eb and provide them with cgame_mp_x86.dll.

Edited by foxdie, 20 October 2010 - 06:29 PM.


#17
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
Can you give more specific information? The silent mod has been tested with fully updated punkbuster, with all versions from 0.1.4 upwards without any problems.

#18
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
Thank you foxdie for information and help. We chatted for a while and made some tests and this problem is indeed in the mod. The reason for the failed tests (not getting kicked) were elsewhere.

Also, the response in the pbbans thread was correct too. Creating eb ticket can solve the problem but also takes time to work. Apologies for claiming it wasn't. We are working on this problem and probably hellreturn will inform you when we have working solutions.

#19
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3099 posts
216
On the road to fame
  • LocationPoland
The ticket has been submitted, one by hellreturn and one bye me. All that is left to do now is to sit and wait :P

Edit: Also, please try to use pb_sv_restrictions 0 in your PB config.

Edited by hellreturn, 26 October 2010 - 10:06 PM.


#20
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3099 posts
216
On the road to fame
  • LocationPoland
Here is the response from Even Balance:

This kick is usually caused by one of the following progams running. Disabling them should stop the kick.

Ventrilo Chat Overlay
Team Speak Overlay
DxTweaker
ATI Tray Tools (depends on version)
Game Accelerator (uninstall, then reboot)
Mumble Overlay
EVGA Precision tool


In case you run Steam, please do the following:

* Open Steam
* Go to File-Settings
* Go to the tab in-game
* Uncheck the "Enable Steam Community In-Game" checkbox
* Press OK
* Restart Steam


If you do not have any of these programs running, open this ticket back up and state what you do have running, especially anything that might be similar to the above.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users