Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

clanforge/shrubbot and admin levels returing to zero


  • Please log in to reply
36 replies to this topic

#1
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

hi peeps any help greatly appreciated:

 

started server which uses clanforge, we have no driect access to the install via ftp only rad only access.

 

silent is running very well and we can set admin levels using the rcon console in clanforge. this works until we disconnect and then admin levels return to 0 and xp is not retained!!!!

 

this is copy of server.cfg:

 

// MOTD
+set dedicated 2 +set net_ip 85.236.100.60 +set net_port 27960 +set fs_game silent +set g_tyranny 1
set server_motd0 "^7Welcome to ^9Saints ^2& ^9Sinners"
set server_motd1 "No Aimbots"
set server_motd2 "No Haxs"
set server_motd3 "No Shoving"
set server_motd4 "No Recruiting"
set server_motd5 "^3Have Fun!"

// PUBLIC INFO
sets .IRC ""                     // your IRC channel + server here (optional)
sets .Admin ""                    // Make it your IRC or site nick maybe (optional)
sets .Email ""                    // You're email address (optional)
sets .URL ""                     // your website here (optional)
sets .Host "http://www.MultiPlay.co.uk"            // host website here (optional)
sets "URL" ""                    // your website here (optional)

// Passwords
set g_password ""            // set to password protect the server pw =
set sv_privateclients ""            // if set > 0, then this number of client slots will be reserved for connections
set sv_privatepassword ""    //
set rconpassword ""            // remote console access password =
set refereePassword ""            // referee status password

// MASTER SERVERS TO REPORT TO
set sv_master1 "etmaster.idsoftware.com"
set sv_master2 "master.gamespy.com:27900"
set sv_master3 "master0.gamespy.com"
set sv_master4 "clanservers.net"
set sv_master5 ""

// Match Setttings
set match_latejoin "1"
set match_minplayers "4"
set match_mutespecs "0"
set match_readypercent "75"
set match_timeoutcount "3"
set match_timeoutlength "180"
set match_warmupDamage "1"

// Team settings
set team_maxPanzers "-1"
set team_maxplayers "0"
set team_nocontrols "0"

// Misc Settings
set g_privateMessages 1
set g_dropAmmo 3
set g_misc 105
set g_spreeOptions 1023
set g_useralliedrespawntime 15
set g_useraxisrespawntime 15
set g_heavyWeaponRestriction "100"
set g_antilag "1"
set g_altStopwatchMode "0"
set g_autofireteams "1"
set g_complaintlimit "6"
set g_ipcomplaintlimit "3"
set g_fastres "0"
set g_friendlyFire "1"
set g_minGameClients "8"
set g_maxlives "0"
set g_alliedmaxlives "0"
set g_axismaxlives "0"
set g_teamforcebalance "1"
set g_noTeamSwitching "0"
set g_voiceChatsAllowed "4"
set g_doWarmup "0"
set g_warmup "15"
set g_spectatorInactivity "0"
set match_latejoin "1"
set match_minplayers "4"
set match_mutespecs "0"
set match_readypercent "75"
set match_timeoutcount "0"
set match_warmupDamage "1"
set team_maxplayers "0"
set team_nocontrols "1"
set pmove_fixed "0"
set pmove_msec "8"
set g_defaultHitSounds "1"
set g_mapScriptDirectory "$$ConfigPathRelative$$"
set g_shrubbot "shrubbot.cfg"
set g_dbUserMaxAge ""

set g_shuffle_rating 3

// LMS ONLY SETTINGS
set g_lms_teamForceBalance "1"
set g_lms_roundlimit "3"
set g_lms_matchlimit "2"
set g_lms_currentMatch "0"
set g_lms_lockTeams "0"
set g_lms_followTeamOnly "1"

// Vote Settings
set g_allowVote "1"
set vote_limit "5"
set vote_percent "50"
set vote_allow_comp "1"
set vote_allow_gametype "1"
set vote_allow_kick "0"
set vote_allow_map "1"
set vote_allow_matchreset "1"
set vote_allow_mutespecs "0"
set vote_allow_nextmap "1"
set vote_allow_pub "1"
set vote_allow_referee "0"
set vote_allow_shuffleteams "1"
set vote_allow_swapteams "1"
set vote_allow_friendlyfire "0"
set vote_allow_timelimit "0"
set vote_allow_warmupdamage "1"
set vote_allow_antilag "1"
set vote_allow_balancedteams "1"
set vote_allow_muting "0"

// Downloads
set sv_wwwCheckPath ""
set sv_wwwBaseURL "http://redirect.mult....co.uk/files/et"
set sv_wwwDownload "1"
set sv_dl_maxRate "42000"
set sv_allowDownload "1"
set sv_wwwDlDisconnected "0"
set sv_wwwFallbackURL ""

// Game settings
set g_antilag "1"
set g_disableComplaints "3"
set g_maxlives "0"
set g_friendlyFire "1"
set g_teamForceBalance "0"
set g_noTeamSwitching "0"
set fraglimit "0"
set timelimit "$$timelimit$$"

// Fun wars
set g_sniperwar 0
set g_panzerwar 0
set g_riflewar 0

// Inactivity kicks
set g_spectatorInactivity "120"
set g_inactivity "120"

// Logs
set g_log "server.log"
set logfile 2
set g_logOptions 0
set g_logAdmin "adminlog.log"
set g_cheatLog "cheat.log"
set g_adminProtection "7"

// XP Save configuration
set g_XPSave 31
set g_XPSaveMaxAge_xp "30d"
set g_XPSaveMaxAge "12o"
set g_damageXP "1"
set g_damageXPLevel "50"
set g_maxXP "900000"
set g_xpdecay "0"
set g_xpdecayrate "0"
set g_xpdecayfloor "1"
set g_maxXPResetWarn "0"
//set g_punkbuster 1

// Shrubbot and Database
set g_dbDirectory "database"
set g_dbUserMaxAge "12od"
set g_minConnectLevel "0"
// see documentation about tyranny enabled commands and flags
set g_tyranny "1"
set g_greetingPos "0"
set g_warningOptions "3"
set g_warningDecay "24"
set g_maxWarnings "3"
set g_autoTempBan "0"
set g_autoTempBanTime "1800"



// Protection
set sv_pure "1"
set g_voiceChatsAllowed "4"
set sv_floodProtect "1"
set sv_maxPing "0"
set sv_minPing "0"
set sv_maxRate "50000"
set sv_minguidage "0"
set g_adminProtection "7"        // This will enable all logging so you can see who authenticates to what level and if the authentication is succesfull or not.
set g_protectMinLevel "2"        // The minimum level of the protected admins
set sv_punkbuster "1"
PB_SV_Enable

// Map Rotation
exec $$ConfigPathRelative$$/campaigncycle.cfg            // Campaign mode
//exec $$ConfigPathRelative$$/objectivecycle.cfg            // Objective mode
//exec $$ConfigPathRelative$$/lmscycle.cfg                // Last Man Standing mode

// Watchdog

// in case the game dies with an ERR_DROP
// or any situation leading to server running with no map
set com_watchdog 10                        // defaults 60
set com_watchdog_cmd "exec $$ConfigPathRelative$$/campaigncycle.cfg"    // defaults to quit

 

--------------

i suspect that the install structure may be wrong but ca not do anything about this re: ftp access. thisis pic of install structure:

 

as said any help greatly appreciated

 

thxs in advance


Edited by jizz, 20 January 2013 - 08:07 PM.


#2
OFFLINE   clan DIABOLIK

clan DIABOLIK

    Advanced Member

  • Members
  • PipPipPipPip
  • 322 posts
36
Getting Better

Hi !

 

Your problem comes from "set g_XPSaveMaxAge "12o""  the unit is in seconds so you dont save xp a lot



#3
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

ofc didnt see that (smacks head)...any idea as to why shrubbot does not retain admin levels??



#4
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

were are you executing your silent.cfg ?



#5
OFFLINE   Ray

Ray

    Member

  • Members
  • PipPip
  • 48 posts
5
A step in the right direction
  • LocationFinland
Hi !

 

Your problem comes from "set g_XPSaveMaxAge "12o""  the unit is in seconds so you dont save xp a lot

I changed the value it into 2592000s, but it still doesn't save the XP's.

 

Edit:

admin levels seems to be stored now.


Edited by Ray, 20 January 2013 - 09:51 PM.


#6
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

@hh: is that not simply a matter of instructing server.cfg to load shrud: -set g_shrubbot "shrubbot.cfg"?

 

sorry new to this!! should explain ....me and ray doing this together so he is referring to same thing;)


Edited by jizz, 20 January 2013 - 09:52 PM.


#7
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3097 posts
216
On the road to fame
  • LocationPoland

Please visit our wiki for the details of how the shrubbot works in silEnT mod.

http://mygamingtalk....Silent_Shrubbot

 

You need to have g_dbDirectory set to have shrubbot working.

I can see that you have it set to "database" but I don't see this directory in the listing you posted.



#8
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3097 posts
216
On the road to fame
  • LocationPoland

I would also recommend visiting installation page:

http://mygamingtalk....od_Installation



#9
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

hi silencer, this is one of issues....i can not work out how to set the database in clanforge as .db is not one of the associated files and no ftp write access?

clanforge support not the best when it comes to et so we are kinda shooting in the dark....especially when clanforge tech ask us what shrub is^^



#10
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3097 posts
216
On the road to fame
  • LocationPoland

Generally it all should work after you unzip the silent.zip. After that it's only a matter of tuning.

However it all depends on the service provider and integration of their scripts. I don't know clanforge and how they handle mod installation and what you have available. Please tell them that you need the directory structure as in the silent.zip file from our release package. Anyone here has any experience with clanforge?



#11
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

Hi jiz,

You have to have the silent.cfg execute from your server.cfg, you upload it via clanforge in the configs tab of the profile your editing.

Once that is done it should create all the default files and things it needs.

I'm not sure what version they uploaded in clanforge as I have ftp access to my machine.



#12
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK
 Anyone here has any experience with clanforge?

Clanforge isnt like that, it does everything for you, is easy once you know what your doing, the multiplay staff try.



#13
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

tbh 'we' prolly made it harder for ourselves.....so i have uninstalled silent, reuploaded the release zip pointed to by silencer and asked clanforge to uninstall and reinstall as per the file structure contained in the zip, this way any mistakes by 'us' will not hinder progress.

 

@hh i appreciate you must be a busy bee but would you have the time to help us set it up just the basic structure in terms of what to upload etc and where....



#14
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

sorry I cant tonight, I'll try tomorrow.

How are creating your silent profile ? through clanforge with the create profile button.



#15
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

@ hh no no m8 i appreciate that....anytime you have free we will fit in with you.....it will prolly take a bit of time for clanforge to uninstall and reinstall mod......and yes i created profile through clanforge profile,button.

 

would it be poss to hit you up on skype/msn tomorrow night sometime...my skype/msn adi is dpsholt@gmail.com


Edited by jizz, 20 January 2013 - 10:45 PM.


#16
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

are you around tomorrow ?

I'll try creating a new silent profile in the morning if I get chance, test it to see if it works and then let you know how I got on, I'll have more of an idea how to help you then.

One last question, have managed to get a plain ET server running via clanforge yet ?



#17
OFFLINE   jizz

jizz

    Newbie

  • Members
  • Pip
  • 12 posts
0
Unknown

arrgh m8 you are a star.....yes i am about from about 8am till 3pm then work till 8.30pm(rl sucks) but i can be got hold of anytime between those times and after 8.30.

 

yes we managed to get plain et install running but was v vanilla no alterations or shrub running etc infact it is still up we have just deleted the silent profiles



#18
OFFLINE   Ray

Ray

    Member

  • Members
  • PipPip
  • 48 posts
5
A step in the right direction
  • LocationFinland

This version is now running on the server: Enemy Territory ( v2.60b )

 

I'll go play Angrybirds while I wait for you guys. :ph34r:


Edited by Ray, 21 January 2013 - 09:44 AM.


#19
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

sorry it was easier to explain off the forum, I think everything is sorted now :)



#20
OFFLINE   Ray

Ray

    Member

  • Members
  • PipPip
  • 48 posts
5
A step in the right direction
  • LocationFinland

omg harry what a cluster****...the 1st tech made us a new profile (nq) and loaded them to there and then said didnt know what he was doing so we had to raise a ticket^^






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users