Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Hitsounds


  • Please log in to reply
7 replies to this topic

#1
OFFLINE   Hitman

Hitman

    Member

  • Members
  • PipPip
  • 35 posts
11
A step in the right direction

hello guys,

 

I have made a custom sound.pk3 file and added sounds in there sound/hitsounds/head.wav and same body.wav and team.wav and uploaded to server and my g_hitsounds flag is 9 but i still here old hitsounds not what i have put in the server any help please?



#2
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame

Did you upload that pk3 to your mod folder?



#3
OFFLINE   Hitman

Hitman

    Member

  • Members
  • PipPip
  • 35 posts
11
A step in the right direction

yes uploaded to silent folder and server downloads it

 

btw i have tried to make a new folder in hitsounds so i tried this also

 

sound/hitsounds/silent/.wav files but then the server not even downloading that pk3 file and yes ofc my .pk3 file is in Silent folder and i did in console ingame /play sound/hitsounds/body.wav but its doing nothing so after i added new folder in my pk3 that silent in hitsounds i tried this comand again with this /play sound/hitsounds/silent/body.wav and it was playing default body.wav file not what i have create i think it doing it because the server is not even downloading that .pk3 file if i put a silent folder in hitsounds folder . :/



#4
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

The hit sounds have to be in a .pk3 file which contains the directory

sound\hitsounds

and named the same as the ones you want to replace or that's how ours work.

 

z_hh_silent_sound1.pk3\sound\hitsounds\head.wav



#5
OFFLINE   Hitman

Hitman

    Member

  • Members
  • PipPip
  • 35 posts
11
A step in the right direction

i got sound.pk3 /sound/hitsounds/head.wav and my flags is 9 for hitsounds but still the server loading old sounds



#6
OFFLINE   Hitman

Hitman

    Member

  • Members
  • PipPip
  • 35 posts
11
A step in the right direction

ok now it works perfectly but 1 more thing by default i see all clients are /cg_hitsoundtype 1 so they still listening silent mod hitsounds how can i make they listen only to my custom hitsounds?



#7
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3096 posts
216
On the road to fame
  • LocationPoland
ok now it works perfectly but 1 more thing by default i see all clients are /cg_hitsoundtype 1 so they still listening silent mod hitsounds how can i make they listen only to my custom hitsounds?

 

You could ask them :) But seriously, why would you want to do that? Let them listen to the sounds they wanna listen to. Different people have different hit sound preferences. If they like your hand made sounds they will switch to it for sure. Just let them know that they can choose it by changing the cg_hitsoundtype cvar, either through the menu or in the console. You could do that by the banner for example. Many people don't know of that possibility to change the hit sounds in silEnT.



#8
OFFLINE   Hitman

Hitman

    Member

  • Members
  • PipPip
  • 35 posts
11
A step in the right direction

+1 agree thanks :D






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users