Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

can't start the server

- - - - -

  • Please log in to reply
6 replies to this topic

#1
OFFLINE   poopie

poopie

    Newbie

  • Members
  • Pip
  • 1 posts
0
Unknown

Hello, i'm not sure if this is the correct section to post this, but my friend is trying to install silent mod on his et server, but when he runs it he gets this:

 

 execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Bypassing CD checks
Found high quality video and fast CPU
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: black.bttdm.com
Alias: black
IP: 192.210.229.209
Started tty console (use +set ttycon 0 to disable)
couldn't exec silent.cfg
execing preset_high.cfg
Hitch warning: 1118 msec frame time
WARNING: watchdog will trigger in 4 seconds
Idle Server with no map - triggering watchdog
Shutdown tty console
[root@black .etwolf]#
 
I'm really a noob at this stuff and so is he, but we want to test the silent mod on the server..
Any help would be appreciated. Thank you in advance!


#2
OFFLINE   Sol

Sol

    Regular Member

  • Coders
  • PipPipPip
  • 113 posts
28
On a distinguished road
  • LocationPoland
Idle Server with no map - triggering watchdog

You need to startup server with any map, for example with start command: +map oasis



#3
OFFLINE   clan DIABOLIK

clan DIABOLIK

    Advanced Member

  • Members
  • PipPipPipPip
  • 322 posts
36
Getting Better

 

couldn't exec silent.cfg

 

 

Maybe because "+exec silent.cfg" is missing in command-start or you have made a file server.cfg instead ?

So no map is played.

 

Good Luck with your server ! 



#4
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

The silent.cfg is in the etmain when unzipping the downloaded silent package. If you copied only the silent directory to the server, please also copy the silent.cfg. It can be put to silent directory also if you like. The unzip places it to etmain for historic reasons only.



#5
OFFLINE   Bluemax

Bluemax

    Member

  • Members
  • PipPip
  • 37 posts
8
A step in the right direction
  • LocationWisconsin

Your command line should be similar to this!

etded +set dedicated 2 +set fs_game silent +exec silent.cfg



#6
OFFLINE   Bluemax

Bluemax

    Member

  • Members
  • PipPip
  • 37 posts
8
A step in the right direction
  • LocationWisconsin

More information would be helpful as well, is the server on a rented host or is is local pc (home net) 

I have a Home net PC with Windows and one with Linux running ET Server for testing Maps/Mods and also a rented host through Dediserverhosting,com as well.

 

 

 

 

Thanks Bluemax



#7
OFFLINE   Patriot

Patriot

    Newbie

  • Members
  • Pip
  • 10 posts
5
A step in the right direction
  • LocationDenmark

Make sure you have this files

etmain:

server.cfg or silent.cfg and make sure you exec a maprotation file like objectivecycle.cfg in the server or silent.cfg, also make sure the objectivecycle.cfg (or whatevernameucallit) is in etmain.

 

silent:

the silent client pk3, the qagame.mp.i386.so (Linux) or the qagame.mp.i386.so (Windows)

 

in the root of your et you should have a startscript

here is mine its for Linux

#!/bin/bash

opts="+exec whatever.cfg +set net_port 27960 +set net_port_extra 27970 +set fs_homepath /opt/games/et3.0 +set fs_game silent +set g_dbMaxAliases 6 +sets gamestartup \"`date +"%D %T"`\""

while [ 1 ]; do
	./etded $opts
done

finally make sure that the maps your calling for in your map.cfg (objectivecycle.cfg) also is placed into your etmain :)

 

hope it helps






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users