Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Problem: Server Disconnected - Missing name field in userinfo

missing userinfo

Best Answer gaoesa, 17 September 2014 - 03:48 PM

Ok. That is a custom menu for changing names made by the admins of the server. The problem is that the menu is updating the name to the server after each keystroke. So when you have deleted the name, it is updating the server with an empty name. You have found a clear bug, but it is in this case caused by custom server modifications.

 

I tested our menus, which worked correctly when backspacing.

Go to the full post »


  • Please log in to reply
7 replies to this topic

#1
OFFLINE   Meva

Meva

    Member

  • Members
  • PipPip
  • 20 posts
4
A step in the right direction

Hi,

I'm doing on the server nick generator and when i want to change my nick in this generator, (I remove the nick) server kicked me. 

 

Reason:

069839ba55b4b3dea06c0f5436f42867.jpg

 

 

This is problem with the bad server configurations or silent mod?

Other silent servers which have the nick name generator, had this same problem as me.


Edited by Meva, 17 September 2014 - 02:52 PM.


#2
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

What is a nick name generator? You always have to have a name on the server. I.e. empty names are not allowed.



#3
OFFLINE   Meva

Meva

    Member

  • Members
  • PipPip
  • 20 posts
4
A step in the right direction

This is a button under ESC in game main menu. When I click this button, it opens me this generator. I removed the nick but does not accept it and server kicked me. 

This is my video. 

https://www.youtube....eature=youtu.be



#4
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
✓  Best Answer

Ok. That is a custom menu for changing names made by the admins of the server. The problem is that the menu is updating the name to the server after each keystroke. So when you have deleted the name, it is updating the server with an empty name. You have found a clear bug, but it is in this case caused by custom server modifications.

 

I tested our menus, which worked correctly when backspacing.



#5
OFFLINE   Meva

Meva

    Member

  • Members
  • PipPip
  • 20 posts
4
A step in the right direction

I tested our menus, which worked correctly when backspacing.

Sorry, but i think that doesn't understand you. Could you explain it? 



#6
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame

Sorry, but i think that doesn't understand you. Could you explain it? 

 

He is basically saying that issue is with the custom menu and not with silent mod menu. silent mod menu works fine.



#7
OFFLINE   Meva

Meva

    Member

  • Members
  • PipPip
  • 20 posts
4
A step in the right direction

OK. thanks guys :) I'm going to fix this problem :)



#8
OFFLINE   Meva

Meva

    Member

  • Members
  • PipPip
  • 20 posts
4
A step in the right direction

ok i'm fix up my problem :) 

This:

 

"Nick:", .2, 8, "name", 36, 18,

changed to:

 

"Nick", .2, 8, "limboname", 36, 28, copyCvar limboname name,

and works ;)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users