Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

MOTD not displaying


Best Answer Dragonji, 29 January 2015 - 03:51 PM

Try this:

set server_motd0 "message 1"
set server_motd1 "message 2"
set server_motd2 "message 3"
set server_motd3 ""
set server_motd4 ""
set server_motd5 ""
Go to the full post »


  • Please log in to reply
3 replies to this topic

#1
OFFLINE   ETsneak

ETsneak

    Regular Member

  • Members
  • PipPipPip
  • 110 posts
19
On a distinguished road

Whenever I connect to my silent server the MOTD doesn't display at all. I'm using three of the available lines and no matter which lines I try it doesn't show up at all. No, I'm not using black text. IT looks like this in the config:

set server_motd0 ""
set server_motd1 "message 1"
set server_motd2 "message 2"
set server_motd3 ""
set server_motd4 "message 3"
set server_motd5 ""

But with color codes applied, and slightly longer messages.

Including spaces, color codes, and all other characters the motds have a max length of 32 in my config.

 

I have two lua modules which I've tried disabling and still have the issue.

Silent version is 0.8.2.

 

 

Here's some output from the console:


anny\1\g_heavyWeaponRestriction\100\g_gametype\6\g_antilag\1\g_voteFlags\0\g_alliedmaxlives\0\g_axismaxlives\0\g_minGameClients\0\g_needpass\1\g_maxlives\0\g_friendlyFire\0\sv_allowAnonymous\0\sv_floodProtect\0\sv_maxPing\0\sv_minPing\0\sv_maxRate\45000\sv_hostname\^fNsA Silent ^7NoBots 100k XPS\sv_privateClients\0\mapname\adlernest\protocol\84\timelimit\15\version\ET 3.00 - TB 0.7.1  - 2.60b compatible linux-i386\sv_maxclients\28
Start of round.
Cheat logfile open: log_cheat.log
readconfig: loaded 6 levels, 0 bans, 0 subnet bans, 1 commands, 0 warnings and 0 custom votes
Execing default.cfg mapconfig for 0 players.
  * Execing commands for player amount between 0 - 12.
  * Execed total of 40 commands from the config file.
Execing adlernest.cfg mapconfig for 0 players.
  * Execed total of 2 commands from the config file.
serverstats: loaded 4 mapstats
banners: loaded 8 banners
*=====INITIALISING USER DATABASE
  * Opening user database file userdb.db.
  * Opening user database file userxdb.db.
  * User database files open. Caching database.
  5 players cached from the user database.
  No additional user records in the user database.
  * Reading aliases database.
  Read total of 9 aliases for 5 players.
*=====DATABASE READY FOR USE
Enable spawning!
Disable spawning!
0 teams with 0 entities
-----------------------------------
Setting MOTD...
Lua API: Loading chat.lua
Lua API: Loading spec.lua
Spec Command loaded
^2Omni-bot is currently disabled with "omnibot_enable 0"
Info string length exceeded
broadcast: print "^'If you suspect a cheater, don't announce it in chat. Demo and post on forum.\n"
broadcast: print "^'XPSave resets at: ^f100,000\n"
Sending heartbeat to etmaster.idsoftware.com
Sending heartbeat to master0.etmaster.net

The line that I suspect is "Info string length exceeded". I've got zero "sets" in the config and g_serverInfo is set to "1".

 

 



#2
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame

Try from rcon and see if you get any ouput for below:

 

server_motd1

 

If you don't then one of your config is overwriting the cvar to blank one. 



#3
OFFLINE   Dragonji

Dragonji

    Advanced Member

  • Members
  • PipPipPipPip
  • 514 posts
142
On the road to fame
  • LocationPoland
✓  Best Answer
Try this:

set server_motd0 "message 1"
set server_motd1 "message 2"
set server_motd2 "message 3"
set server_motd3 ""
set server_motd4 ""
set server_motd5 ""


#4
OFFLINE   ETsneak

ETsneak

    Regular Member

  • Members
  • PipPipPip
  • 110 posts
19
On a distinguished road

Try from rcon and see if you get any ouput for below:

 

server_motd1

 

If you don't then one of your config is overwriting the cvar to blank one. 

 

It outputs exactly what I have in the config.

 

Try this:
 

set server_motd0 "message 1"
set server_motd1 "message 2"
set server_motd2 "message 3"
set server_motd3 ""
set server_motd4 ""
set server_motd5 ""

 

This fixed it thankyou






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users