Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

0.9.0 Can't Connect

- - - - -

  • Please log in to reply
15 replies to this topic

#1
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

I have several folks who can't connect to our server... or any 0.9.0 server.

 

They get a message about impure client.    They were fine before I updated the server.  Any ideas?



#2
OFFLINE   Purple

Purple

    Advanced Member

  • Banned
  • PipPipPipPip
  • 157 posts
56
Getting Better

silent mod dev team 10/10 :D & whats your ip ill try to connect.


Edited by Purple, 23 November 2015 - 03:29 AM.


#3
OFFLINE   Zelly

Zelly

    Regular Member

  • Coders
  • PipPipPip
  • 141 posts
73
Getting Better

Are you sure you updated the server correctly? I would verify that first.

 

qagame.so/dll replaced and the silent-0.8.2.pk3 replaced by silent-0.9.0.pk3?

 

Also check server logs and client console logs see if it says anything else.


 

Hopefully the issue is with how you updated mod and not an issue with clients updating normally. (If it is silent dev will have to chime in :P)

 

Might be the way I have my et setup but I have not had any issues joining 0.9.0 or 0.8.0 servers like I expected.

 

 

I was tired okay.. leave me alone :P


Edited by Zelly, 23 November 2015 - 05:40 AM.


#4
OFFLINE   Purple

Purple

    Advanced Member

  • Banned
  • PipPipPipPip
  • 157 posts
56
Getting Better

 

Are you sure you updated the server correctly? I would verify that first.

 

qagame.so/dll replaced and the silent-0.8.3.pk3 replaced by silent-0.9.3.pk3?

 

Also check server logs and client console logs see if it says anything else.

 

Hopefully the issue is with how you updated mod and not an issue with clients updating normally. (If it is silent dev will have to chime in :P)

 

Might be the way I have my et setup but I have not had any issues joining 0.9.0 or 0.8.3 servers like I expected.

 

where are you getting these 3's from 0.9.0 and 0.8.2



#5
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

68.232.172.16

 

I deleted my silent folder.  Replaced with the silent folder I downloaded.  But replaced shrubbot and database folder with backed up version (to maintain xp and history).  On the server, that is.


Edited by roissgil, 23 November 2015 - 04:09 AM.


#6
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

After some searching the unpure client error looks to be an old thing that can happen from time to time for various reasons. The common suggestions for clients enabling downloads and completely restarting the game. Apparently ET Legacy etlded has a fix for it, or for some form of it. Sorry I can't give exact resolutiom for the issue, but it's not a mod issue and I'm not familiar with the problem.



#7
OFFLINE   Dragonji

Dragonji

    Advanced Member

  • Members
  • PipPipPipPip
  • 514 posts
142
On the road to fame
  • LocationPoland

http://dev.etlegacy.com/issues/14

 

If this is the problem, installing newest ET:L instead of etded should help.



#8
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

After some searching the unpure client error looks to be an old thing that can happen from time to time for various reasons. The common suggestions for clients enabling downloads and completely restarting the game. Apparently ET Legacy etlded has a fix for it, or for some form of it. Sorry I can't give exact resolutiom for the issue, but it's not a mod issue and I'm not familiar with the problem.

 

I get what you're saying, but I think it's more than coincidence that I have 3 people who connected fine to our server before I put up 0.9.0 and now they can't.

 

I'm checking with them on what OS, client (ET:L or not) and anything else they can tell me.



#9
OFFLINE   Purple

Purple

    Advanced Member

  • Banned
  • PipPipPipPip
  • 157 posts
56
Getting Better

I get what you're saying, but I think it's more than coincidence that I have 3 people who connected fine to our server before I put up 0.9.0 and now they can't.

 

I'm checking with them on what OS, client (ET:L or not) and anything else they can tell me.

Tell them to delete their silent mod folder and reconnect.



#10
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

OK.. so I have one guy who still can't connect.  the other guy ran his game as administrator and that fixed him.

 

The guy who still can't connect is on a Mac.  He was able to connect to an ETPub server, and was able to connect to our server before I updated to 0.9.0.

 

He has deleted his silent folder completely, and still can't join.

 

Here are the answers to the questions I posed him....

 

1) are you using ET Legacy? No
2) what OS you are on? Mac 10.6.8
3) can you connect to any other 0.9.0 server? No
4) do you have the silent-0.9.0.pk3 in your silent folder? Yes
5) what does the console say after you try to connect? There's no console notation, the game closes. Then there's a loooong string of stuff that includes everything about my computer and the game.

 

So, seems like a Silent issue with Mac ?  Help?



#11
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

Ask him to put the silent-0.9.0-pk3 to the silent directory by hand.



#12
OFFLINE   Purple

Purple

    Advanced Member

  • Banned
  • PipPipPipPip
  • 157 posts
56
Getting Better

Users with OSX are having the same issues on my forums as well, heres one for example..

6zEVh1g.jpg



#13
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

ET 2.60d (OS X version) has a known issue with downloading mods. Maps and custom pk3s download and expand normally. Placing the silent pk3 is a requirement for playing with 2.60d, I don't know if ET Legacy for OS X has addressed that issue.



#14
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

Ask him to put the silent-0.9.0-pk3 to the silent directory by hand.

 

They did... still not working.



#15
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

We have only tested with 10.10 OS X and using ET Legacy. It is possible that our binary is no longer compatible with so outdated OS X version. The good news is that OS X upgrades are free and ET Legacy works.



#16
OFFLINE   roissgil

roissgil

    Member

  • Members
  • PipPip
  • 24 posts
2
A step in the right direction

Thanks!  I'll let them know.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users