Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Can't join with OSX

- - - - -

  • Please log in to reply
4 replies to this topic

#1
OFFLINE   ailmanki

ailmanki

    Member

  • Members
  • PipPip
  • 27 posts
6
A step in the right direction
I didnt notice earlier, cause I always play with Windows, but I configure my server from OSX.. so I join it from time to time. And now I cannot anymore.

It tells me the token PPSH is unknown in human anim script.



#2
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
That is common error when the correct binary is not loaded. JamesPlock plays with Mac OSX without any problems. One thing we know is that if the server is configured to disconnect for the downloads, the mod download will fail in Mac. Have you tried manually installing the mod binary.

Maybe too many pk3 files is one possibility.

#3
OFFLINE   ailmanki

ailmanki

    Member

  • Members
  • PipPip
  • 27 posts
6
A step in the right direction
I tried again with a clean install, did not help, so I checked OSX error msgs..

7/11/11 1:02:45 AM Wolfenstein ET[1507] Error loading /Users/ailmanki/Library/Caches/TemporaryItems/etmain/ui_mac.bundle/Contents/MacOS/ui_mac: dlopen(/Users/ailmanki/Library/Caches/TemporaryItems/etmain/ui_mac.bundle/Contents/MacOS/ui_mac, 262): no suitable image found. Did find: /Users/ailmanki/Library/Caches/TemporaryItems/etmain/ui_mac.bundle/Contents/MacOS/ui_mac: mach-o, but wrong architecture

I deleted that folder under Caches - same result. I got et 2.60d if that matters?

Well .. next thing I checked is the processes, ET was running as a PowerPC process.. kinda strange for me.
So I checked the wolfenstein.app, and found the executable - "file" says me its built for multiple architectures, so I tried starting it from command line - Woo.. ET started now as a Intel process.. So I tried joining that server again - and it works now.





I have a custom machine running OSX, so I suppose something is wrongly configured which makes ET run the PowerPC version. I suppose its not related to silEnTmod.



#4
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
Yes. Seems correct. We don't include the PowerPC binaries anymore. Only Intel binaries.

#5
OFFLINE   ailmanki

ailmanki

    Member

  • Members
  • PipPip
  • 27 posts
6
A step in the right direction
For your information, the error happened cause I used a tool to start ET, http://epecafsoft.ho...et/~epecafsoft/

Even though the tool runs as Intel Process, it starts ET as PowerPC process.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users