Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

XP do not save after server restart


  • Please log in to reply
5 replies to this topic

#1
OFFLINE   kino

kino

    Regular Member

  • Members
  • PipPipPip
  • 55 posts
2
A step in the right direction

Hi!

 

I am working actually some hours to get XP saved after a server restart.

XP will be saved if i do NOT restart the server. I tried following cvars from

Wiki:

set g_XPSave 21 
set g_dbUserMaxAge "365d" 
set g_XPSaveMaxAge_xp "365d" 
set g_XPSaveMaxAge "365d" 

That settings do not works. Then i tried this:

set g_XPSave 23 
set g_dbUserMaxAge "365d" 
set g_XPSaveMaxAge_xp "365d" 
set g_XPSaveMaxAge "365d" 
set g_XPSaveMinXP "-1"
set g_maxXP "-1"

Same here, same problem.

 

I do not get a error message in console or smth else. Admin lvl's will be saved

after a server restart. I've checked "database". I cannot find a file where XP

should be saved. And there is a .cfg calls userxdb.db wich is empty. Is that 

file relevant for getting XPSave working?

 

I hope you could help me because i do not know what i could do more...

 

Thanks



#2
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

this is mine, try it and see if it works, if it does edit it to suit your needs.

// XP Save configuration
set g_XPSave 31  //changed from 21
set g_XPSaveMaxAge_xp "5d"  //changed from "30d"
set g_damageXP "0"  //changed from "1"
set g_damageXPLevel "50"
set g_maxXP -1  //changed from "90000"
set g_xpdecay "0"
set g_xpdecayrate "0"
set g_xpdecayfloor "0"  //changed from "1"


#3
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

Make sure on your startup you do not have any map commands before you have set up the cvars to correct values. This is a common issue with wrongly formed startup. The g_XPSave is 0 when the mod is started by the map command and the setting is set after.



#4
OFFLINE   kino

kino

    Regular Member

  • Members
  • PipPipPip
  • 55 posts
2
A step in the right direction

Thanks for your answer gaoesa!

 

But i think i do not understand you. You mean something like that: 

set d1 "set g_gametype 2 ; map goldrush ; set nextmap vstr d2"


#5
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

Yes. The map command on that line makes the engine start the silEnT mod. You should have your XP save cvars set before the first time the map comand is executed by the engine. The mod will otherwise delete old stored XP on initialization. In otherwords, if you have for example "exec silent.cfg" after "exec mapcycle.cfg" you should reverse the order of the exec commands on the command line.
 

This describes most of the common issues:
http://mygamingtalk....od_Installation



#6
OFFLINE   kino

kino

    Regular Member

  • Members
  • PipPipPip
  • 55 posts
2
A step in the right direction

 

this is mine, try it and see if it works, if it does edit it to suit your needs.

// XP Save configuration
set g_XPSave 31  //changed from 21
set g_XPSaveMaxAge_xp "5d"  //changed from "30d"
set g_damageXP "0"  //changed from "1"
set g_damageXPLevel "50"
set g_maxXP -1  //changed from "90000"
set g_xpdecay "0"
set g_xpdecayrate "0"
set g_xpdecayfloor "0"  //changed from "1"

Thank you, that works!!

 

And thanks gaoesa!!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users