Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Problem patching my silEnT server with 2.55+

- - - - -

  • Please log in to reply
6 replies to this topic

#1
OFFLINE   carnage

carnage

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown
Soo... I have run into a problem while trying to patch my server with 2.55+ (which makes the server accessible to players from both 2.55 and 2.6b patches):
Debian-50-lenny-64-LAMP:/home# ./et-linux-2.55.x86.run
Verifying archive integrity... All good.
Uncompressing Enemy Territory 2.55...........................................................................................................................................................................................................................................................................................................
This installation doesn't support glibc-2.0 on Linux / unknown
(tried to run setup)
See http://zerowing.idsoftware.com/linux/ for troubleshooting
The setup program seems to have failed on unknown/glibc-2.0

Then I tried to install this pack:
Debian-50-lenny-64-LAMP:/home# apt-get install glibc-2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package glibc-2.0

Then i found a 2.55 folder (I don't know if these are the right files or not), copy pasted them into test server, and I got this error:
Sys_LoadDll(/home/silent255/enemy-territory//silent/qagame.mp.i386.so)...
Sys_LoadDll(/home/silent255/enemy-territory//silent/qagame.mp.i386.so) failed:
"liblua5.1.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/home/silent255/enemy-territory/silent/qagame.mp.i386.so)...
Sys_LoadDll(/home/silent255/enemy-territory/silent/qagame.mp.i386.so) failed:
"liblua5.1.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(qagame) failed dlopen() completely!
----- Server Shutdown -----

I was told I was missing the liblua5.1.so file that was included in the package, so I copied it, but still got another problem:
Sys_LoadDll(/home/silent255/enemy-territory//silent/qagame.mp.i386.so)...
Sys_LoadDll(/home/silent255/enemy-territory//silent/qagame.mp.i386.so) failed:
"liblua5.1.so: wrong ELF class: ELFCLASS64"

It'd be great if you knew how to fix this issue, because I seem to have no idea of how it works.

Server info can be found here.
Thanks in advance.

Link to the original topic (trackbase).

#2
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3097 posts
216
On the road to fame
  • LocationPoland
Please post the output of the following command:
ldconfig  -p | grep liblua
It should return something like this:
liblua5.1.so (libc6) => /usr/lib/liblua5.1.so
or nothing.

If the first command succeeds then please post the result of the following one:
file <the right side of the output> so for example:
file /usr/lib/liblua5.1.so


#3
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
One thing to know is that you can turn 2.60b server into 2.55+ server by replacing the etded file. Also if you do it like that you need to delete few files that are not present in 2.55 installations so that the clients would not get missing official pk3 file notices when connecting.

From the first error message I suspect you are using 64 bit linux and in that case you need to run the installer in 32 bit compatibility mode. Also, you need to have compatibility libraries installed because the required glibc is quite old and not present in most systems automatically.

"sudo linux32 ./et-linux-2.55.x86.run" might work the installation for you.

#4
OFFLINE   TheSilencerPL

TheSilencerPL

    Advanced Member

  • Management
  • PipPipPipPip
  • 3097 posts
216
On the road to fame
  • LocationPoland
Yes. What I was trying to check is to see whether there isn't the 64 bit version of liblua library installed already on the system. Probably it is loaded before the one provided by us. But try gaoesa's advice first.

#5
OFFLINE   carnage

carnage

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown

One thing to know is that you can turn 2.60b server into 2.55+ server by replacing the etded file. Also if you do it like that you need to delete few files that are not present in 2.55 installations so that the clients would not get missing official pk3 file notices when connecting. From the first error message I suspect you are using 64 bit linux and in that case you need to run the installer in 32 bit compatibility mode. Also, you need to have compatibility libraries installed because the required glibc is quite old and not present in most systems automatically. "sudo linux32 ./et-linux-2.55.x86.run" might work the installation for you.

Replacing the etded file actually worked, thanks. But I don't seem to know exactly which files to delete. pak1, pak2 and then?

Edited by carnage, 05 November 2011 - 03:41 AM.


#6
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame
mp_bin.pk3
pak1
pak2

deleting above 3 should work :)

#7
OFFLINE   carnage

carnage

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown

mp_bin.pk3
pak1
pak2

deleting above 3 should work :)

It works now! Many thanks to everyone. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users