Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Sword of the Stars II: Lords of Winter Update Released

- - - - -

  • Please log in to reply
No replies to this topic

#1
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2693 posts
158
On the road to fame
r21284c
-----

Critical fixes:
+ Fixed a new core bug that was leading to AI expansion, design and
fleet composition issues.
+ Fixed a crash that might occur if a homeworld was eliminated.
+ Fixed an admiral and Suul'ka related crash.

Other fixes:
+ Fixed a rendering error that was causing particle effects to LOD out early.
+ Fixed a bug that was allowing players to see enemy systems if they
had naval stations.
+ Fixed hiver gate, badge icon, naval icon and homeworld effect
persistence upon re-entering the star map.
+ It is now possible to build stations in independent systems.
+ Fixed a case where a player could attempt to send two colonization
missions to a system with one habitable planet.
+ Fixed an issue that was preventing the star system tool tip from
appearing in the first few turns.
+ Fixed an issue that was making clicking to zoom in on a fleet tricky.
+ Fleets no longer disband automatically when relocated unless there
is not enough support capacity available.
+ Fixed an issue that was causing Suul'ka to bore node lines.
+ Station retrofit now has a scrollbar for weapon lists.
+ Fixed the issue that was preventing freighters from moving in combat.
+ Recent survey effects are now excluded from your own systems.
+ AI now retires obsolete designs.

View the full article




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users