Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

No Quarter - NOQ MySQL installation

- - - - -

  • Please log in to reply
3 replies to this topic

#1
OFFLINE   CptPhynex

CptPhynex

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown

Hello community,

 

I would like to install the Next generation game (NOQ) for No Quarter v1.2.9 b6 to save the XP in a MySQL database.

 

Everything works fine but the console log say he misses some files.

 

no field package.preload['luasql.mysql']
no file '/home/.../.../nq/luasql/mysql.lua'
no file '/home/.../.../nq/lualibs/luasql/mysql.lua'
no file '/home/.../.../nq/lualibs/luasql/mysql.so'
no file '/home/.../.../nq/lualibs/luasql.so'
 
It's mysql.lua and luasql.so. Do anyone of you know where I can find or how I can build them?

Edited by CptPhynex, 04 December 2015 - 08:05 PM.


#2
OFFLINE   CptPhynex

CptPhynex

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown

Okay, fixed it.

 

New error:

libmysqlclient.so.15: wrong ELF class: ELFCLASS64

 

Anyone know how to fix this?



#3
OFFLINE   Zelly

Zelly

    Regular Member

  • Coders
  • PipPipPip
  • 141 posts
73
Getting Better

guess from my general knowledge: your current libmysqlclient.so was built for a different distribution of linux, takign a guess from the '64' maybe you have wrong architecture of the file.



#4
OFFLINE   CptPhynex

CptPhynex

    Newbie

  • Members
  • Pip
  • 3 posts
0
Unknown

Solved this problem yesterday by downloading the 32Bit Libs (and placed them also into ET Folder).

 

Only one error left:

Lua API: et_ClientConnect error running lua script: [string "noq/noq.lua"]:1274: This process needs an active shell to be executed.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users