Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Silent 0.5.2 problem xpsave


  • Please log in to reply
20 replies to this topic

#1
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Hi. I have problem with xpsave. I want XP forever, but when I restart server XP gone . I don't know why :/. My XPsave and DB cfg.
Spoiler


Please Help me.

#2
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
Does the XP save work over map changes?

Please post snippets from the log with the database opening and closing. The very first database entry when the server is restarted may have usefull information if the reset happens only on server restarts.

#3
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Yes. It's work on next map. Only when I restart server XP gone.


Opening:

Spoiler


Closing:
Spoiler

Edited by oleczek7, 05 July 2012 - 11:31 PM.


#4
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
Do you have PB GUID. Just in case your silent guid is changing for any reason. With PB GUID we can be sure that is not the case. Please check the cvar values of g_dbUserMaxAge, g_XPSaveMaxAge and g_XPSaveMaxAge_xp. Also, please make sure that the executed map command is the last to get executed in the server cfg. I.e. exec "objectivecycle.cfg" or what it is that you may be using is executed last. This because the mod loads at that point and if you do not have g_XPSave set to the value before the mod loads it will reset the XP.

EDIT:
Ment that you should check the 3 cvars using rcon on the server. But I think the most likely reason is wrong order in setting g_XPSave and executing map rotation.

#5
OFFLINE   Dookie

Dookie

    Advanced Member

  • Members
  • PipPipPip
  • 383 posts
55
Getting Better
  • LocationCroatia
Try using this:


set g_XPSave "21"
set g_XPSaveMaxAge_xp "12o"
set g_XPSaveMaxAge "12o"
set g_damageXP "0"
set g_damageXPLevel "50"
set g_maxXP "-1"
set g_xpdecay "0"
set g_xpdecayrate "0"
set g_xpdecayfloor "0.0"

#6
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Maybe here is a problem. I don't have PB Guid, but I don't know why. I have etkey and when I type pb_myguid I can see my guid.

Picture:
Spoiler


Dookie I used this and it's doesn't work :/

Edited by oleczek7, 06 July 2012 - 11:40 AM.


#7
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
Do !updatepbguid [name|slot]. It seems that the PB GUID is not stored in the database. The update must be done manually to prevent exploits coming from two unique keys.

The issue in the screenshot happens when your record is first created without PB GUID. However, this would imply that a changing silent guid is not the problem. If it was, you would probably have the PB GUID stored because there would be new record created for you.

After restarts, do you still have your admin level or does both XP and admin level clear?

#8
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
I used !updatepbguid and now I have PB Guid, but stil don't have Xp save :/. I have admin level after restart.

#9
OFFLINE   Dookie

Dookie

    Advanced Member

  • Members
  • PipPipPip
  • 383 posts
55
Getting Better
  • LocationCroatia
oleczek7, add me on my xfire: znemo


I will help you out trought it. thanks!

#10
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Ok . I will add you today.

#11
OFFLINE   Dragonji

Dragonji

    Advanced Member

  • Members
  • PipPipPip
  • 412 posts
105
On the road to fame
Could you post your whole config file? Just hide your passwords first.

Edited by Dragon, 07 July 2012 - 06:34 PM.


#12
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Ok. There is my cfg:
Spoiler


#13
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
The cfg looks good. Could you please post the command line also?

#14
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Sorry, but I don't understand what command line ? :)

#15
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
This

etded +set fs_game silent ... +exec silent.cfg


#16
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
etded.x86 +set fs_basepath /home/servers/s25353 +set fs_homepath /home/servers/s25353 +set dedicated 2 +exec server.cfg +set net_strict 1 +set sv_maxclients 14 +set net_ip 80.82.16.66 +set fs_game silent +exec silent.cfg +set net_port 27992 . Only this I can change => +set fs_game silent +exec silent.cfg rest are blocked

#17
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland
Please check the server.cfg does not have a map command or exec objectivecycle.cfg or anything. Would be better if you could post it here. Just remove any private data from it if necessary.

#18
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
set dedicated "2" // 1: dedicated server for lan 2: dedicated server for internet

// PASSWORDS & CLIENTS

set g_password "serverpassons"
set sv_privateclients "0" // if set > 0, then this number of client slots will be reserved for connections
set sv_privatepassword "" // that have "password" set to the value of "sv_privatePassword"
set rconpassword "rconpassons"
set refereePassword "" // referee status password

// DL, RATE

set sv_maxRate "13000" // 10000 standard but poor for ET
set sv_dl_maxRate "42000" // increase/decerease if you have plenty/little spare bandwidth
set sv_allowDownload "0" // global toggle for both legacy download and web download
set sv_wwwDownload "0" // toggle to enable web download
set sv_wwwBaseURL "" // base URL for redirection
set sv_wwwDlDisconnected "0" // tell clients to perform their downloads while disconnected from the server
set sv_wwwFallbackURL "" // URL to send to if an http/ftp fails or is refused client side

// MOTD ETC

set sv_hostname "Enemy Territory @ Zabijaka.pl"
set server_motd0 " ^NEnemy Territory ^7MOTD " // message in right corner of join screen here
set server_motd1 ""
set server_motd2 ""
set server_motd3 ""
set server_motd4 ""
set server_motd5 ""

// MISC SETTINGS

set g_heavyWeaponRestriction "100"
set g_antilag "1"
set g_altStopwatchMode "0"
set g_autofireteams "1"
set g_complaintlimit "6"
set g_ipcomplaintlimit "3"
set g_fastres "0"
set g_friendlyFire "1"
//set g_gametype "4" // Game type should be set from map rotation script
set g_minGameClients "8"
set g_maxlives "0"
set g_alliedmaxlives "0"
set g_axismaxlives "0"
set g_teamforcebalance "1"
set g_noTeamSwitching "0"
set g_voiceChatsAllowed "4"
set g_doWarmup "0"
set g_warmup "30"
set g_spectatorInactivity "0"
set sv_floodProtect "1"
set sv_allowDownload "1"
set sv_pure "1"
set sv_minping "0"
set sv_maxping "0"
set match_latejoin "1"
set match_minplayers "4"
set match_mutespecs "0"
set match_readypercent "100"
set match_timeoutcount "0"
set match_warmupDamage "1"
set team_maxplayers "0"
set team_nocontrols "1"
set pmove_fixed "0"
set pmove_msec "8"

// LMS ONLY SETTINGS

set g_lms_teamForceBalance "1"
set g_lms_roundlimit "3"
set g_lms_matchlimit "2"
set g_lms_currentMatch "0"
set g_lms_lockTeams "0"
set g_lms_followTeamOnly "1"

// VOTING

set g_allowVote "1"
set vote_limit "5"
set vote_percent "50"
set vote_allow_comp "1"
set vote_allow_gametype "1"
set vote_allow_kick "1"
set vote_allow_map "1"
set vote_allow_matchreset "1"
set vote_allow_mutespecs "1"
set vote_allow_nextmap "1"
set vote_allow_pub "1"
set vote_allow_referee "0"
set vote_allow_shuffleteams "1"
set vote_allow_swapteams "1"
set vote_allow_friendlyfire "1"
set vote_allow_timelimit "0"
set vote_allow_warmupdamage "1"
set vote_allow_antilag "1"
set vote_allow_balancedteams "1"
set vote_allow_muting "1"

// PUNKBUSTER

// sv_punkbuster is a readonly variable. Use +set sv_punkbuster on command line or use the command pb_sv_enable in the console
//pb_sv_enable

// LOGGING

set g_log "etserver.log" // Game logging
set g_logsync 0
set logfile 0 // Console logging ( 1: enable 2: enable and sync )

// MAP ROTATION

exec campaigncycle.cfg // Campaign mode
//exec objectivecycle.cfg // Objective mode
//exec lmscycle.cfg // Last Man Standing mode

// WATCHDOG

// in case the game dies with an ERR_DROP
// or any situation leading to server running with no map
//set com_watchdog 10 // defaults 60
set com_watchdog_cmd "exec campaigncycle.cfg" // defaults to quit


#19
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPip
  • 3819 posts
246
On the road to fame
  • LocationFinland

exec campaigncycle.cfg // Campaign mode


This line in the server.cfg seems to be the problem. The campaign cycle does start the mod because it has the map command inside. The watchdog command is probably irrelevant but I recommend removing that one too. It is enough when these are in the silent.cfg.

EDIT:
The issue is that the server.cfg is executed first and the silent.cfg after. It is better to have only one cfg in the command line to avoid problems.

#20
OFFLINE   oleczek7

oleczek7

    Member

  • Members
  • PipPip
  • 18 posts
0
Unknown
Thanks man it's work!!! :). You are awsome :D.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users