Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Silent server cfg cvar setting on g_classWeapons


  • Please log in to reply
5 replies to this topic

#1
OFFLINE   RaNeR

RaNeR

    Regular Member

  • Members
  • PipPipPip
  • 80 posts
2
A step in the right direction
HELLO...
Running Silent 5.2 with omni-Bots 0.8.1....
When I set this cvar to "7" the engee and fildops bots run around with pistols...
If I set it to "0" then they all have there pirmary weapons...

g_classWeapons

Description
This cvar enables certain weapons per class. So far, only PPSH enablement is implemented:
Parameters
Type: bitmask
1 Enable PPSH for soldiers
2 Enable PPSH for engineers
4 Enable PPSH for fieldops
Default: 7
My problem is some of the players like to use the PPSH ...

Has anyone run into this problem...and if you did what did you do to fix it...
Thanks Raner...

#2
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
You need this file http://www.omni-bot.com/forum/showthread.php?2998-How-to-assign-a-particular-gm-to-a-particular-Bot-!&p=18740&viewfull=1#post18740

The problem is that in the default installation of omnibots the bots don't know how to use he weapon and that is why they run around with pistols.

#3
OFFLINE   RaNeR

RaNeR

    Regular Member

  • Members
  • PipPipPip
  • 80 posts
2
A step in the right direction
Thanks......
gaoesa I got it...installed the gm see how it goes...how if life treating you lately...good I know ...LOL ...Later Dude...

#4
OFFLINE   RaNeR

RaNeR

    Regular Member

  • Members
  • PipPipPip
  • 80 posts
2
A step in the right direction
Well Gaoesa the Weapons Silent ppsh gm is installed...but no go...The engee and field ops bots to back to pistols if I set...
g_classWeapons to "7" if I set it to "0" everything is fine..
What setting are you using on your server...
Maybe I can try something else...Thanks Raner...

#5
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
Indeed. The weapon number was changed in cooperation with crapshoot and that is why the old file does not work. Try changing the line
WEAPON.PPSH = 101;
To
WEAPON.PPSH = 50;
inside the file weapon_silEnT_ppsh.gm.

#6
OFFLINE   RaNeR

RaNeR

    Regular Member

  • Members
  • PipPipPip
  • 80 posts
2
A step in the right direction
Well Dude...you are the man...WEAPON.PPSH =50; did it...
g_classWeapons "7" is set and everything looks good...bots working fine as far as primary weapons and the ppsh is available to everybody well everybody playing on the server that is ...LOL...Thanks for the help and catch you later....




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users