Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

ETEng release 0.3

- - - - -

  • Please log in to reply
35 replies to this topic

#21
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK
We thought it was but it looks as if its stopped again, our hosts are looking in to it but we may not an answer back until next week now.
PB looks to be running on the machine but we're getting nothing from like its not working, but there are no errors showing anywhere.

confused ? we are :rolleyes:

#22
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
Using PB on server with ETEng should not be possible. The rebuild of the binary will miss all the interactions with the PunkBuster because those were not released with the GPL source.

#23
OFFLINE   icecom3

icecom3

    Newbie

  • Members
  • Pip
  • 6 posts
0
Unknown
any way of coordinating with equalone to make a 2.55+ version as a protocol? As apposed to only having either 2.55 or 2.60b?

#24
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
The 2.55+ is not a protocol. Take a look at
Added: sv_protocolcheck {0,1}: 0-Server doesn't check clients protocols, 1-Server allows only one protocol of sv_protocol.
Added: sv_protocol {82,84}: 82- 2.55 Protocol, 84 - 2.6b Protocol, This is shown in getinfo.
It is already possible to disable the protocol check.

#25
OFFLINE   icecom3

icecom3

    Newbie

  • Members
  • Pip
  • 6 posts
0
Unknown
oh i see, if its disabled it does not care what version...great!

Nice work by the way.

#26
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

Using PB on server with ETEng should not be possible.

The light has been shone, confused no more :)

#27
OFFLINE   icecom3

icecom3

    Newbie

  • Members
  • Pip
  • 6 posts
0
Unknown
The cvars go in server.cfg right?

Also, I would advise some documentation in this zip, as easy as it seems, and as obvious as the fixes are to some, major hosts may be hesitant to add this file because of the lack of documentation.
I just requested that gameservers.com add this file and edit the command line (since I don't have access), and they have said no in the past for things like 2.55+ patch and QMM...etc (until hundreds of people finally ask them).

Respectfully...

#28
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

The cvars go in server.cfg right?

Yes, I've put ours at the very end.

they have said no in the past for things like 2.55+ patch and QMM...etc (until hundreds of people finally ask them)

Our host are the opposite ? they've changed ours over but we cannot have two executables on the machine for the same game, so this means we have lost our NQ server as NQ doesn't support this executable :( we have been told of another one that we could use NQ with but that one doesn't support ETPro.
So we've had to choose which we use, our hosts want this one.

#29
OFFLINE   hellreturn

hellreturn

    Management

  • Management
  • PipPipPipPip
  • 2692 posts
158
On the road to fame

I just requested that gameservers.com add this file and edit the command line (since I don't have access), and they have said no in the past for things like 2.55+ patch and QMM...etc (until hundreds of people finally ask them).


They should change it if not, tell them you would leave and move to another host. It's pathetic from gs.com not to support good patches. I use them as host as well for one of my server. I haven't requested as of yet but I am planning to do by this weekend. Let me know what they say to you.

#30
OFFLINE   icecom3

icecom3

    Newbie

  • Members
  • Pip
  • 6 posts
0
Unknown
@ gaoesa

"./eteng.x86: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./eteng.x86)"
glibc too new for what gameservers uses on all of its ET servers I think :(
I have a virtual image of debian etch appliance ready to compile glibc 2.3.6 if you want it

@ HarryHomers
have you tried quake multimod (QMM), it works on NQ. I am trying to retire it on my servers though, as I think most mods already have its fixes.

Edited by icecom3, 28 April 2012 - 04:43 AM.


#31
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland
@icecom3

I'm not part of the ETEng team. This is sols project. I hope he has time to fix the issue you reported.

#32
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 246 posts
54
Getting Better
  • LocationCornwall, UK

@ HarryHomers
have you tried quake multimod (QMM), it works on NQ. I am trying to retire it on my servers though, as I think most mods already have its fixes.

yes I've tried it but I still get the same error and server shutdown.
--- Starting NQ server check ... ---
^1Error: No Quarter doesn't support ET version ETENG 0.3 linux-i386 Mar 25 2012.
Upgrade to 2.60b for Win/Linux or 2.60d for Mac.
:(

#33
OFFLINE   Sol

Sol

    Regular Member

  • Coders
  • PipPipPip
  • 113 posts
28
On a distinguished road
  • LocationPoland
I'm sorry, but I had no time.
The project is closed and connected to ET:Legacy (http://etlegacy.com/)

^1Error: No Quarter doesn't support ET version ETENG 0.3 linux-i386 Mar 25 2012.
Upgrade to 2.60b for Win/Linux or 2.60d for Mac.

Yes, this is a bug in the /version/ server flag, but anyway new version of ET: legacy will be built all the functions of ETEng

Edited by Sol, 28 April 2012 - 04:25 PM.


#34
OFFLINE   icecom3

icecom3

    Newbie

  • Members
  • Pip
  • 6 posts
0
Unknown
Here is ETeng with the compatible glibc for gameservers.com.

Sol,
Aside from you not developing this anymore, what are the road blocks for adding PB support?

#35
OFFLINE   MARZ

MARZ

    Newbie

  • Members
  • Pip
  • 4 posts
0
Unknown
I'm sorry, but I had no time.
The project is closed and connected to ET:Legacy (http://etlegacy.com/)


Yes, this is a bug in the /version/ server flag, but anyway new version of ET: legacy will be built all the functions of ETEng

so whois behind ET ENG 0.7 linux-i386 Sep 16 2012 ??



#36
OFFLINE   Dragonji

Dragonji

    Advanced Member

  • Members
  • PipPipPipPip
  • 514 posts
142
On the road to fame
  • LocationPoland

Sol and I. We continue it for own needs.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users