Jump to content

Photo

Bot glitching with a specific PLANT goal on Ruins of Acquiesce


  • Please log in to reply
2 replies to this topic

#1
OFFLINE   Mateos

Mateos

    Member

  • Members
  • PipPip
  • 30 posts
8
A step in the right direction
  • LocationFrance

Good evening,

 

Axis bots seem to have trouble planting the Closet Door on that map; they keep switching between planting and roaming at a fast pace

 

With the current waypoint on Assembla repo, with a little timescale command, you can quickly see an Axis Engi bot doing the necessary to reach that goal then glitch as pointed above

 

Seen locally and online on a dedicated server

 

Map download link: https://www.wolffile...ilebase&fid=771

 

Could someone please take a look?


Edited by Mateos, 28 June 2022 - 04:54 PM.


#2
OFFLINE   palota

palota

    Newbie

  • Moderators
  • 14 posts
17
On a distinguished road

That ruins32.gm script is for old Omni-bot version 0.71. The Map.Switches table does not work since Omni-bot 0.8. and has to be converted to SWITCH goals. The MOVER_tank goal should be removed. But the most critical bug is that all priorities are extremely high. Priorities of normal high level goals should never be greater than 0.9.



#3
OFFLINE   Mateos

Mateos

    Member

  • Members
  • PipPip
  • 30 posts
8
A step in the right direction
  • LocationFrance

Alright, I'll adjust these things; didn't know it could cause that much trouble, thank you

 

Edit: Even MOVER_tank, used by ESCORT and MOUNT goals?


Edited by Mateos, 29 June 2022 - 08:31 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users