Jump to content

RtCW -The bots are not used with MG42 guns

Recommended Posts

I'll try to summarize: the RtCW Multiplayer developers gave me 2 engines one is rtcwPub and the other is rtcwPubj.
The Pub is the player only engine and the Pubj is the same with bots support. I use both, but my questions here are only for the Pubj engine. 

I had a dream come true when we installed them, but I encountered some problems :)
I have always been a RtCW 1.0 player, sometimes I use 1.4. 
The observation is that the W@R server runs under windows, and on it runs a very old omnibot 0.83 (I think). Playing on the server I am happy to see that the bots use the MG42 cannons, which ours which is 0.85 omnibot refuse to do so. A long time ago (at least 10 years ago) on another bot server I saw that they not only use the cannons but also repair them!

I rent a VPS server and use ubuntu linux 18.4, that's what I run the Pub and Pubj servers on. The latter is 0.85 with omnibots shared. You wrote to tell me the map name: none of the maps work with this feature!

I will share some links, maybe they can give some information: 

Is this enough information to start with?

Edited by PuNkReAS
Link to comment
Share on other sites

  • 3 weeks later...

- Because there is no other modality available to me at the moment
- Yes, I know the developer, but he's not available for 1 year...
- The source code I believe is unique to him and he hasn't made it available, but I'll try to get it.

In the meantime we found out that for some reason the 0.85 version bots are not used, but the 0.87 version bots are used occasionally, but the cannons are not fixed...

Link to comment
Share on other sites

But I would really like to use the omnibot! (My English may be bad, so I'm not very clear, sorry) 
Pubj has the omnibot built-in. Since the developer disappeared, so CU (Clans United) / s4ndmod will be tried. The omnibot works great with the latter. I think I will be able to share the source code for the s4ndmod or CU mod with you! Would that be helpful?

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...
On 4/26/2023 at 6:37 PM, PuNkReAS said:

Thank you! Yes in the meantime we did some tests...unfortunately then it seems the Pubj engine has some bug.

The problem is somewhat solved. The Pubj engine was using 0.85 bots, now using the cU engine + 0.87 omnibots works! The bots are using their beds! 
For some reason they don't fix them, but I can be happy about that now! :)

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

cU was an international clan called 'Clans United'. They also made their own mod for RtCW, which I was able to get with the help of our member Beer. He dusted off the old engine and integrated the omnibot 0.87 version into the mod and it works perfectly! For some reason, the Pubj mod with omni 0.85 doesn't work perfectly, but the cU engine with omni 0.87 does! 
Why is it better? Maybe because it's now 2023 development, updated, improved, with new features (multiple game mods) but I'm sure Beer can tell you! He is the only one who can help you with downloading, I only use the latest version of the mod on my server. But I will let you know now so he can respond to your question.

Question. I see Mateos has published version 0.89 Woohooo! What can I know about it? Is it possible to test it?

Link to comment
Share on other sites

  • 5 months later...

I have to write again, unfortunately, before all the rest of my hair falls out prematurely 😆
Just to complicate the situation I can't figure out what is causing this phenomenon.
- Beer development Pub + OB/0.90 - no treatment for cannons. 
- Tarator upgrade Pubj + OB/0.90 - for me they handle the cannons.
- cU engine (Beer dev.) OB/0.87 - the bots handle the cannons.
I got an old s4ndmod engine (ultimate) maybe OB/0.83 version not only to handle the cannons but also to fix them! I could not believe my eyes. Can my dream come true if I can use the oldest engine? Only that my current server is not running in s4nd ultimate (chaosmod) mode...

Mateos mentioned that the cannon usage depends on the .gm file of the map (I hope I interpreted it correctly). Just to make it more complicated, I tried using a map and bots file from last year on the oldest engine. And it works! 
I can't understand how it is that the oldest engine DOES THIS and why the newest one doesn't?

I'll give you the map and bots files and you can check it out for yourselves and see if you get the answer :) https://rtcw.hu/dev/

Test server: /connect 

Edited by PuNkReAS
Link to comment
Share on other sites

  • Moderators

Only Beer knows why this is happening. He is the only one who can fix it. I can't do anything because I don't have Pub mod or cU engine. He refused to give them to me. I don't understand why he wants to keep his mods private.

s4ndmod is free and open source. Everybody can download it. It works with Omni-bot 0.90, if you update the version number and recompile it from source code.

Link to comment
Share on other sites

Hello palota,

The cU Mod is bases on S4ndmod, what is public, so they use mg42.

The thing is on s4ndmod the mod is lagging on bigger maps and if more bots are playing..

Only on rtcwpub, they dont even see it or use it. I think its a mod / engine related thing.

It includes the mod and engine in the same solution.

I would you include in the Github, where i got my actualy work on rtcwpub. Maybe you can have a look on it whats wrong

Il invited you in my Github Project


Cheers Beer

Edited by Beer
Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)

Guys, there's a map that could provide a really tough challenge if it worked the way I envisioned. How to get the bots to use the cannons? This map is explicitly favorable (at least 6 MG42's are located) yet it is used sporadically by the bots. The question is specific: I want the cannons in the fortress (4 of them) to be used by the bots! So: how?
I don't care if the map is difficult for the players, that's the challenge. 

MAP: wolf files

The mod I use: cU 6.2 + OB0.9

Server: /connect




Edited by PuNkReAS
Link to comment
Share on other sites

From what I see from the GitHub repository, these goals are limited to Soldiers, and have a changed priority, which may change how goals are done by bots

omni-bot/0.83/Installer/Files/rtcw/nav/final_deathwish.gm at stable · jswigart/omni-bot (github.com)

Even the flag is limited to Soldiers, weird...

Comment-out the limits and check ingame if other goals have higher priority

Else handle that with roles

Edited by Mateos
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...