Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Log In with Steam Sign In
  • Create Account
Photo

Server restarting on loading custom campaign


  • Please log in to reply
31 replies to this topic

#1
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

I'm having a problem with my Silent server.

I have a custom campaign cycle/pk3 installed and for some reason whenever I try loading the custom campaign the server either restarts or crashes. 

Was wondering if anyone else has come across this problem with their server and if so if there is a way around this?



#2
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

it could be a few things, what is in your pk3, have you changed anything else on server ?



#3
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

The only thing that is in the pk3 file is a campaign file and that is it though I've changed the following in the server.cfg

exec objectivecycle.cfg to exec campaigncycle.cfg including the one in the watchdog setting.

 

Those are the only things that have been changed.



#4
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

it must be something in the pk3 file ? fancy posting it ?



#5
OFFLINE   ETsneak

ETsneak

    Regular Member

  • Members
  • PipPipPip
  • 110 posts
19
On a distinguished road

If you have any errors in the server console or log during the crash, posting those would be helpful as well. If there are no errors you could still post the output because it may be useful.


Edited by ETsneak, 11 January 2014 - 05:44 AM.


#6
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

Sorry for the late reply guys. 

It seems that I haven't quite got it right in my first post. 

 

To be continued...



#7
OFFLINE   Petbark

Petbark

    Advanced Member

  • Members
  • PipPipPipPip
  • 185 posts
30
Getting Better

Also with campaigns you need to make sure you have no name errors for the maps and that all the maps are in the right location.



#8
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

The problem is this. In the silent wiki there is no entry at all about campaigns so I presume it has not changed from ETpub. The situation is this , if the server config is left as objectivecycle the sever starts and runs fine and the first admin to login can switch to a campaign. But this has to be done manually. If you set the server config to campaigncycle the server hangs. Even when gametype is changed to 4 which is campaign. 



#9
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

I tested with campaigncycle.cfg that is found from etmain and I didn't have any problems.

 

Do you have this kind of entry in your campaign file?

// server doesn't recognise the campaign command when the gamecode isn't running yet.
set d_initial "set g_gametype 4 ; map oasis ; set nextcampaign vstr d2"
vstr d_initial


#10
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

ours at the moment  is

set d1 "clearspreerecords ;  campaign hhbotmulti172 ; set nextcampaign vstr d2"
set d2 "campaign hhbotmulti173 ; set nextcampaign vstr d1"

// server doesn't recognise the campaign command when the gamecode isn't running yet..
set d_initial "set g_gametype 4 ; map Atlantic ; set nextcampaign vstr d1"
vstr d_initial
vstr d1

As we are hosted by Multiplay we are missing " cmpgn_ " from the campaign file names.

The other thing to remember is that the first map name after the game type is the bsp name not the pk3 name.



#11
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

 

I tested with campaigncycle.cfg that is found from etmain and I didn't have any problems.

 

Do you have this kind of entry in your campaign file?

// server doesn't recognise the campaign command when the gamecode isn't running yet.
set d_initial "set g_gametype 4 ; map oasis ; set nextcampaign vstr d2"
vstr d_initial

 

Yep that is what I am getting in the campaign file. 


Edited by Reaper, 19 January 2014 - 02:50 PM.


#12
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

Yep that is what I am getting in the campaign file. 

 

set d_initial "set g_gametype 4 ; map oasis ; set nextcampaign vstr d2"

 

surely the line should be ending in d1 not d2 as its the first run of the server when it starts or crashes, it should be starting at the beginning ?



#13
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

No, that is from a working campaigncycle.cfg that comes with the game and it works. He didn't post his own capaigncycle.cfg yet.



#14
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

okey dokey



#15
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

Here is the campaigncycle.cfg

 

Attached File  campaigncycle.cfg   301bytes   6 downloads



#16
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

And the cmpgn_blitzkrieg starts with oasis?

 

It's been a while since I used campaigns, but if I remember correctly, the started map had to be the one that is first in the campaign.



#17
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

If I remember it right yes, though it wasn't I who created the custom campaign so I'd have to confirm it with the guy who did just to be sure. 



#18
OFFLINE   JohnDory

JohnDory

    Advanced Member

  • Subscriber
  • PipPipPipPip
  • 248 posts
54
Getting Better
  • LocationCornwall, UK

Your first map is oasis, so the line set d_initial "set g_gametype 4 ; oasis ; set nextcampaign vstr d2" should be set d_initial "set g_gametype 4 ; oasis ; set nextcampaign vstr d1"

As you starting with the campaign cmpgn_warzone at the moment which doesn't have the oasis map in it that's why its crashing.


Edited by JohnDory, 19 January 2014 - 06:19 PM.


#19
OFFLINE   gaoesa

gaoesa

    Advanced Member

  • Management
  • PipPipPipPip
  • 4391 posts
341
Will become famous
  • LocationFinland

For reference, here is the full campaigncycle.cfg that comes with the game and works.

set d1 "campaign cmpgn_northafrica ; set nextcampaign vstr d2"
set d2 "campaign cmpgn_centraleurope ; set nextcampaign vstr d1"

// server doesn't recognise the campaign command when the gamecode isn't running yet.
set d_initial "set g_gametype 4 ; map oasis ; set nextcampaign vstr d2"
vstr d_initial



#20
OFFLINE   Reaper

Reaper

    Member

  • Members
  • PipPip
  • 22 posts
9
A step in the right direction

Oh right will edit now and test it out :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users